skip to Main Content

Swiftpage’s Upgrade Pricing Eligibility Policy entitles customers with specific recent releases access to preferred pricing to move to Act! subscription. If you’re using a version of Act! that falls outside the listed versions, you’re not eligible for preferred pricing and will instead need to subscribe to Act! at new customer pricing.

Support obsolescence

Swiftpage’s Support Obsolescence Policy is to support the current release and specific recent releases of a product.

Check here which products are currently eligible for upgrade pricing, and which products are currently supported by Swiftpage.

 

 

Back To Top
Search